RingCentral .Net SDK
Loading...
Searching...
No Matches
RingCentral.Paths.Restapi.Oauth.Revoke.Index Class Reference
Collaboration diagram for RingCentral.Paths.Restapi.Oauth.Revoke.Index:

Public Member Functions

 Index (Restapi.Oauth.Index parent)
string Path (bool withParameter=false)
async Task< string > Post (RingCentral.RevokeTokenRequest revokeTokenRequest, RingCentral.RevokeTokenParameters queryParams=null, RestRequestConfig restRequestConfig=null)
 Revokes all active access/refresh tokens and invalidates the OAuth session basing on token provided. The token parameter may be passed in query string or body and may represent access or refresh token.

Public Attributes

RestClient rc
Restapi.Oauth.Index parent

Member Function Documentation

◆ Post()

async Task< string > RingCentral.Paths.Restapi.Oauth.Revoke.Index.Post ( RingCentral.RevokeTokenRequest revokeTokenRequest,
RingCentral.RevokeTokenParameters queryParams = null,
RestRequestConfig restRequestConfig = null )
inline

Revokes all active access/refresh tokens and invalidates the OAuth session basing on token provided. The token parameter may be passed in query string or body and may represent access or refresh token.

This endpoint is defined by RFC-7009 "OAuth 2.0 Token Revocation"

For confidential client application types this endpoint requires client authentication using one of the supported methods:

  • client_secret_basic - client ID and client secret must be provided via Authorization header as described in RFC-6749.
  • client_secret_jwt / private_key_jwt – client_assertion attribute should be used to pass a signed JWT as described in RFC-7523.

For non-confidential client application types the client identifier must be provided via client_id request attribute.

HTTP Method: post Endpoint: /restapi/oauth/revoke Rate Limit Group: Auth


The documentation for this class was generated from the following file:
  • RingCentral.Net/Paths/Restapi/Oauth/Revoke/Index.cs